[RELEASE] Tasmota for HE - Auto-detecting Tasmota drivers + Tasmota firmware 7.x/8.x for HE (for use with Tuya, Sonoff and other ESP devices)

WARNING: Flashing your device with a 3rd party firmware MAY cause your device to not boot again. To fix this you MAY have to flash through TTL. Don’t be in a rush!

What’s New?
Support for Tasmota v8.5.1 and updates in the custom Tasmota firmware to be even closer to the original firmware. Http Hooks is now the name of the feature needed for integrating with this App and Driver.

Which Devices Work?
Most devices that can run Tasmota work. Some may still need some special care, but most work as long as the template is correct. Read the docs for further information.

My Zigbee Drivers
For those looking for my Zigbee drivers, they can be found here:

Documentation
For full documentation, visit the WIKI !
If you already have Tasmota flashed on your devices, go to this part of the Wiki for installing T4HE .
Don’t forget the CHILD drivers!

Firmware
The latest firmware is available here .

Drivers
Read the Wiki for details . The drivers can be installed using HPM or downloaded from here . Beta drivers can be found here .

Support
Read the documentation , if there are issues, post in THIS thread.

Why This Driver?
There’s a lot of confusion on which Tasmota driver to use with HE, for some reason there are those that have an issue with using a modified version of Tasmota. The only change in my Tasmota firmware is adding a way to push data to HE without using Polling (known to be a bad idea with HE and is NOT real-time) or Rules in Tasmota (doesn’t run as fast as C++ code and is MUCH slower than this firmware). Even the version using Rules is using polling for certain things. There’s also routes using MQTT+Node-RED (or MQTT+something else), this is an advanced solution that is meant for those that truly want maximum flexibility with the trade-off of more work and the need to understand more types of technologies.
My combination of firmware+driver doesn’t use polling and is as optimized as can be.
With this said, if you’re new to using Tasmota, use this driver. If you for some reason don’t want to use a non-original release of Tasmota, understand the limitations of other solutions and live with those.
NO functionality is removed from Tasmota in this custom firmware, nor is this adding a measurable overhead. The code added basically takes the MQTT JSON data and sends it over http to HE. That is all.

Thank You
A big THANK YOU to all the Beta testers and an even bigger thank you to those that wrote the documentation: @garyjmilne, @sebastien and @jchurch.

8 Likes

No issues, just glad to see this thread and release is still alive! I was just bragging about how HE is simply for zigbee sensors for me due to this release and code! Thanks again for all the effort!

2 Likes

@markus I’m running 8.3.1 (your firmware) on my Tasmota devices.

Do I need to just upgrade the devices to your 8.5.1, or go back to the original Tasmota firmware first.

This is what I currently run: Tasmota 8.3.1 by Theo Arends & for Hubitat by markus-li

Which file is correct for upgradeing Tasmota for HE to current firmware?

@Mike

I just did all my Sonoff/Tasmota devices from 8.3.1 to 8.5.1. What I did was backup each devices config in the Tasmota web gui first. Then I flashed them with the 8.5.1 minimal firmware, then flashed them with Tasmota-httphook-851.bin or tasmota-httphook-8.5.1.bin.gz. If I use a device with sensors I used Tasmota-sensors-httphook-8.5.1.bin.gz after the minimal. I had to re-connect this to my wi-fi after the upgrade. I did this by connecting to the wi-fi ssid that each Tasmota devices creates after the update, then connect to 192.168.4.1 and enter the correct wi-fi details (make sure these are 100% correct before saving). I then restored my config backup I made.

Tasmota 8.5.1 from here https://github.com/markus-li/Tasmota-Hubitat/releases/tag/v8.5.1

2 Likes

G’day @Mike! you will need to upgrade to minimal first then apply the full Tasmota bin after. Note If you have a size/space issue when trying to load then you can use the .gz (compressed file) when loading.

Also the settings are retained within the drivers and applied to the device, to be extra cautious I like to note down the template I used and the module settings for my device/s so if I did happen to loose them I have them ready to go. I also like to do a single device first that I can access more easily than others but that’s just a habit/safety net for me to get the hang of a newer version update :slight_smile:

You can find @markus latest Tasmota for HE firmware below.

3 Likes

I did the same except the backup/restore part. I wasn’t sure if it was ok to restore an 8.3 to an 8.5 device. It all worked, I had to be very careful to know what was originally done since starting over with each device basically.
I did not yet re-do the syncing of bulb together into device groups from command line.

Looking for some advice. I’ve had a number of T4HE devices running for a while. Mainly a couple of Sonoff Basics, minis with 2 Gosund plugs. They works perfectly in web UI and when using Tasmoadmin.

The issue I’m experiencing is that occasionally I get a hang up when using Hubitat controls (dashboard or within hub) or via Alexa controls. If I try again it usually works once it’s timed out on the first try. It’s seems very sporadic.

Any ideas what may be causing this behaviour? Any suggestions would be appreciated.

What kind of wifi APs are you suing and how many devices do you have on that network? Do you have any issues with other network-based devices? Like delays/failures sending TTS events?

I have my WiFi running on a pair of Tenda WiFi mesh nodes. The master node plugs straight into my router and I’ve disabled my WiFi on the router itself. There are about 30 devices across both nodes.

I also have a PiHole DNS running on the network. Could this affect things? Networking is clearly not my forte but basically looking to segregate my router from WiFi as was having issues with the router WiFi. Only other thing on the network is Sonos speakers…again unsure if this affects things.

Do you suggest any avenues to research as understand this is likely to be something in my network setup…and therefore not very easy to advise on…

@markus

PMs are not the fastest way for replies, since then it’d be only me replying, just so you know. :stuck_out_tongue:

You can add currently installed Tasmota devices by selecting them from the device list just below the section where you install new devices. Once selected they will not show up when installing new ones. This assumes you are using my current Universal Parent on your Tasmota devices. Any other installed devices would be ignored.

Thanks @markus, I thought this might be very specific to me :grin:

I am still a bit lost on where to discover Tasmota devices in the Tasmota Device Manager, I want it to find the existing devices without it adding them again into my device list.

I tried the manual add, but this then duplicates my devices.

image

Sorry, I might not have been 100% clear. You just add them under “Grant Access to Additional Devices”. You can just select all devices there, the App will determine which ones are Tasmota devices automatically and ignore the rest.

1 Like

This is not very easy to advice on, but there are some basics to check. To which network device is your HE connected? Try to connect to another one (different brand and model) since certain switches and routers don’t work 100% reliable with HE. That could be a first test. The other one is the question regarding that brand of mesh wifi, I don’t have experience with it, but mesh wifi can be problematic when it comes to IoT devices like these sometimes. @RRodman do you know anything in particular regarding these APs?

1 Like

I know things are probably crazy right now, but I was wondering if you had any luck with getting the multi press option working in the driver. Glad to test if you have some code you want tested.

1 Like

Multi-press and button controller stuff should be easier to implement without rules now that Tasmota 9.1 is out.

They changed the response for pressing a button from the rather unhelpful {“ACTION”:“SINGLE”} to {“Button1”:{“Action”:“SINGLE”}}. So now you can easily tell what button was pressed and how.

1 Like

Anyone else getting this error when trying to flash tasmota-minimal-8.5.1.bin to a 8.3.1 sensors-he device?
image
My device is a Sonoff TH-16 humidity and temperature sensor and if I am reading the wiki right I should be flashing the 8.5.1 minimal binary, then the 8.5.1 sensors .gz file but no matter what I do it refuses to take the minimal.

When that happens, try the minimal .gz file. As long as you’re on 8.3.1 or later (mentioning this for those that read this at a later time) .gz files are supported.

1 Like

Perfect, works now, I am guessing there wasn’t enough room to store the uncompressed binary file? Even the minimal version?

There could be fragmentation issues or even bad sectors causing that, so yes, that would be the issue. It’s not consistently a problem, but when it occurs it can be worth using the .gz file. It is however a slower update.

1 Like

Hi, I just flashed my first device ever with tuya convert. I managed to flash tasmota-hubitat-8.3.1.bin, logged into it and could load a template (This is the Kogan USB plug with power meter kogan-KASPEMHUSBA).

I even managed to turn the plug on an off from the web console.

Then i tried installing the device on hubitat. I might have done something wrong here, I tried using the discover devices option instead of the manual one. It did find my device and created those device. As soon as that happened, I am no longer able to use the plug. It seems to have bricked. Powering off/on doesn’t work. The power light just stays on and pressing the physical button doesn’t do anything. I am also no longer able to access the web console.

I see in the logs I might have picked the wrong template
dev:3432020-11-20 11:04:58.340 pm infoThe template is set to ‘{“NAME”:“Brilliant20676”,“GPIO”:[0,0,0,0,0,21,0,0,0,52,90,0,0],“FLAG”:0,“BASE”:18}’ already!
dev:3432020-11-20 11:04:58.335 pm infoSetting the Template ({“NAME”:“Brilliant20676”,“GPIO”:[0,0,0,0,0,21,0,0,0,52,90,0,0],“FLAG”:0,“BASE”:18}) soon…

Any ideas what is going on or how I can fix this?

You need to change to this template

Also did you buy these recently? I was going to get more but figured they would have the new firmware to stop guys convert now.