[smartly] bug report and support thread

Either ask a question here, or in the RELEASE thread. It’s okay either way. If the Q&A grows too long in the RELEASE thread it might be moved here. If that happens we’ll split the thread and leave a descriptive explanation (and screenshots if applicable) in the RELEASE thread so everybody can benefit from the work we’ve done together. :call_me_hand:

If you had a question on this thread in HE community, please re-post it here!


Hi, I’m new to Hubitat and Smartly. Getting a “Cannot read ‘filter’ of undefined” error when trying to save Jason layout. Have tried with existing dashboard and with a freshly created one. It was working with 1.08.
Any ideas?

1 Like

Let’s have you try updating your JSON in v1.08, which still exists here. This will help us narrow down what is causing the error. Let me know!

I have been unable to install using HPM. I have the latest available HPM installed, and it has successfully installed a couple of other packages (Weather.gov, Inovelli drivers). See the pics below for details of the behavior I’m observing:

Everything starts out fine…

Then I see this error

The logs aren’t very illuminating for me

The files are downloaded and once they are about to be installed into the file manager of your HE hub they fail. Check to see if you have files already installed in the File Manger that may conflict with these? If that is not the issue, it’s probably best to contact the HPM developer since the files download properly and they do exist on the paths shown.

1 Like

File manager shows no files whatsoever… pretty new installation and it’s uncluttered :wink:. I’ll cross-post over on the HPM thread and hope for help. Thanks, @markus!


Definitely drop back in here and keep us in the loop. If there is anything we can improve or gotchas we missed, we want to make note of em :v:

1 Like

Will do :+1:



Made a new dashboard with 2 tiles. Ran it through 1.08 and it worked.
Ran the same layout through 2.0 and got “Cannot read property filter of undefined” when trying to save layout


1 Like

Let’s have you PM me with your JSON [smartly] how to send your JSON for troubleshooting so we can get to the bottom of it. :+1:

When I first started using Smartly there were some display issues with my old iPad running IOS 10.3.3. You sorted them out and everything was fine. With the new smartly inject features there seems to be a few issues on the old ipad. The slider dimmers work fine. The color changing temperature tiles don’t work and the Inject Device Tile is visible on the dash. If this is a limitation of the old IOS version that’s fine. The items that do not work on the old ipad are working just fine on my newer ipad.


It sounds like smartly-inject isn’t working correctly on iOS 10.3.3 :hushed: Thank you for letting us know. I’ll have to take a look at this within the ios simulator, and I’m hoping I get to see what’s wrong in the console.

I’ll investigate and will tag you when I know more!

some background on troubleshooting

The first thing smartly-inject does when it loads, is hide the injection tile you’ve created. That’s a clear indicator that it isn’t loading, sadly for your device. The slider dimmers, for the most part, work just fine without smartly-inject. :nerd_face:

1 Like

I sent you a link from postbin. first time trying this and not sure I got right or if I even managed to PM you?


Hi @spelcheck, sorry to hear about the separation, good luck to you and the team in this new venture.
Small thing with smartly 2.0, when I do a title replacement on any tile all the text in the pop-up box field is forced to lower case. The code does actually capitalize where I typed but it doesn’t show in the title replacement field as I typed it. It used to be WYSIWYG but it’s not now, is it supposed to be that way? is it a bug? or am I the only one and I need to debug on my end? Thanks


That is for sure a bug! I think we need to have a bug-hunting badge on here.

Starship Troopers emblem? :smile:

**UPDATE: **@wecoyote5 please try it now!

I just tried it and it sadly was still all lower case. I did a page refresh before I pasted in the dashboard code but when I clicked on a tile all the title text was still lower case.
Let’s get 'em… :slight_smile:

1 Like


Is this what you’re seeing, 2.0 hp2? I just visited and started typing in uppercase letters into the input box and it seemed to work.

The text in the layout json looks fine, it’s the text in the title replacement pop-up box that’s all lower case.
The json looks OK, in this example I’m using ‘Marks Fan’, it looks OK here
but not here.


Very helpful thanks! I’ll get a patch out tonight :v:

I’m struggling to get Parallax to work.
I definitely have it enabled, but on iOS nor in my browser am I seeing anything when I scroll.
Any idea how to trouble-shoot?