ZWave issue - odd error message

Thanks for taking the time to fill out this bug report :hugs:
Make sure there aren’t any open/closed issues for this topic :smiley:
Bug Reports NEED to use this template. Fill in the information below.

Marjebian Version: v1.8.2.0727

Other Related Software Versions:
ZWaveJs2mqtt: 6.5.2
ZWave JS: 8.11.6

Description: (What happened and what should have happened)
I am trying to pair my first device, more as an experiment before doing my whole house. I have a Zooz S2 stick 700 which appears to be working OK. It has never had a firmware update since none seems to be available for the AU version of the stick.

Steps to reproduce behavior:

1: Run the ZWave tool from the core desktop. A healthy ZST10-700 with firmware v7.16 is shown
2: Click Manage Nodes
3. Action “Inclusion”, click Next
4. Enter the location etc then Click Next
5. An error is displayed:

Additional Comments/Information:
At first the device refused to pair a device, an Aeotec SmartSwitch 6, but it has now started to pair OK, which is weird. I will attempt to pair more devices and see what happens.

Typically to harvest logs that you need the command would be sudo oll-ReplaceWithServiceName --logs

paste logs here

you need to generate your security keys.
click the gear and you will see the following lines are blank.
click the generate arrows on the side for each one.
don’t regenerate the ones that are there or you will have to re pair your devices

OK, that did it, after a restart of the service from the command line at least.

Thanks. Tomorrow I will completely dismantle my old Z-Wave network and rebuild in the new. Going to be interesting finding new ways to efficiently do what I used to do.

1 Like

Let me know if you need assistance. Between staff, I have the largest zwave mesh with locks. Start with powered first. Locks are interesting. I’ll await your rapid-fire questions.

No locks here. The thought of putting my security in the hands of ZWave makes me shudder. Maybe when I manage to create and keep a decent mesh that does not randomly spit nodes I will be more comfortable. Every door in my house has Euro locks as well, which I have not seen in ZWave.

I know to start with closest powered then spiral out. Then do the same with sensors. Hopefully the 700 series controller helps me.

1 Like

I have had no problems with zwave mesh on CORE. It’s flawless and stable. If you start with powered devices and work out. I still have my aeotec repeaters placed around the house. they rock.

I will throw something your way. After you pair a few, I find that i need to restart the browser. You’ll see it act like it starts, but then won’t count down. That’s your queue to restart your browser. Mostly I’ve gotten away from restarting the zwave service, but don’t rule it out, but don’t do sudo oll-zwavejs2mqtt --restart because it feels like it takes forever. do sudo oll-zwavejs2mqtt --stop and then the same with start. I have no patience. then if you run that with --status you can watch it start and will know when it’s on line. Usually there’s no need to fully reboot CORE. It’s a beast. Services when restarted actually reload a fresh container.

@relaxton It probably does need an update, here’s the link:

It’s not until this version that they fixed MOST of the issues plaguing the 700 series, do make sure to do the update on a Windows machine, the update command on CORE has been disabled due to the fact that we’ve not been able to test it enough, yet.

1 Like

Thanks, it shits me that Zooz’s own site did not help me to find that link. I will update it before I do any more network building.


What kind of data is supposed to show up in zwavejs2mqtt.

I see my device but the sensor information doesn’t show up?


don’t change the controller information. That could be bad

Yeah, as @april.brandt said, that is the actual controller stick plugged into your Core that you are looking at.

Your actual sensor should have a bunch of nodes under it which provide configuration and activity information. These are often pretty hard to understand without reading the manual, so it is often better to just get out MQTT explorer and exercise the sensor a little. For example my Aeotec Multisensor 6 send values of 0 and 8 on the node /113/0/Home_Security/Motion_sensor_status for no motion and motion. This is also visible in zwavejs2mqtt under the “Notification V3” node.

So, collapse the accordion that has the Controller in it, find your actual sensor, and then take a look at what it is doing.

1 Like

There is a decent description in docs for this and mqtt. I used Z-Wave as an example if you want to take a look there as well.

Thank you. I didn’t want @parish99 to get too inquisitive (clicky) about that controller entry and I was busy with another thing. Thank you for clarifying it.


so is mqtt explorer supposed to already be installed on core?

Not sure what this means, I dont see any other way to find the sensor in the desktop app.

I’d like to see your whole page, can you give me a shot of the entire page for zw2mqtt?
in the photo, you see the area that I circled?
that will open up the device so see what is under it.

No. You need to download it to use it. There are version for many platforms. This caught me up when I was following along as well.

1 Like

This is all that shows up when you expand the arrow.

From my view, you haven’t joined a device. NOw that I can see, I assume that you’re needing to pair a device.
In the top click actions
choose manage nodes
Then you’ll get the options for inclusion/replace/exclusion

1 Like