Paired a 3 outlet strip but cannot see endpoints

I have just connected a zigbee LIDL 3 outlet power strip to CC.
Here is the device info.

Device Details

When I try to select the device in NR I can see the strip but none of the 3 endpoints for the O/L’s.
Is there something that needs to be done or am I missing something totally obvious. (Most probably).

You might need to address this a bit differently. zigbee 2mqtt says it’s fully supported, so it might be an issue with the node. There were some differences in the z2m nodes that were a bit … off. can you post screenshots of the node, one of the list inside the node (the available options). I don’t have one of these, but I’ve been using things long enough that a visual will do.

also try changing the input node to complete state and put a debug with complete message and see what you get out of it.

When I pick the
node I get these options.
I suppose the 3 state options could be the 3 endpoints.

Also when I select the device notes it says the following.
When I install this node to my pallette the command node gives the following. What the heel is a herdsman? :slight_smile:

what is the node name? Are you in NR3?

Not using NR3

1 Like

Herdsman is your z2m protocol. click the list and show me what’s in the herdsman list as well.
target is one of the states
Show the command list after choosing one of the state in the list.

As above

1 Like

Actually, I’m kind’ve looking for the the version of the z2m node. You can find that info easiest in manage pallete . It’ll give you the contrib name and the version you’re using. It would help me.

And if i could have a peek at the command list when target field shows state

Sorry to be asking all of these questions, I’m not at home, so anything visual you can offer me woudl be helpful.

Getting this error.
24/08/2022, 16:42:57node: zigbee herdsmanmsg : error

“Error: PanID must have a value of 0x0001 (1) - 0xFFFE (65534), got 65535.”


Not sure where this is on the nodes I’m using.

OH no … no . I don’t think you want to use that one. stand by. I’ll remote into my home.

Don’t put yourself out on this. I’m happy to leave it and re-visit when you are free. Work comes first.
Thanks for responding so quickly.

I feel like this is a contrib that wants to connect directly to your controller. I’m not using the updated version of this i’m still on 0.6.3 due to the bugs with the nodes.
I’ll tag @RRodman, but did you upgrade the baked in node that was at 0.6.3? Or did you add this yourself? NBD if you did, but I’ve not moved since there too many issues with the new version of nodes.

The 5 nodes I have shown above are what came with CC. I don’t believe I updated any nodes, but hey, I’ve been clicking around so much with NR, as this is the first time I have seen NR, who knows? :wink:

1 Like

I did update the Z2M-node yesterday and the with assistance I was able to revert to 2.3.2, please have a look here:

1 Like

Dump that command node. That’s really confusing. I’m still baffled as to where you found that. You already have z2m set up.
You need to use a trigger that goes into an out node that runs the command

As you see in my flow above:
zigbee motion happens with an in node
it’s filtered from active and inactive which then turns the lights on, but when inactive turns the lights off after 20 seconds. If movement happens, then the timer is stopped until inactive again.
The light off is into an out node for the other zigbee device. All of the commands happen within that node. No extra nodes need to be added to control the device.

You can import this flow and take a look


Thanks for the response and info @april.brandt. I will give it a go later.
What I didn’t make clear before, sorry about that, but I was still expecting to 3 ‘child’ devices (the 3 o/l’s) under the main parent device when the strip was joined.
Should they show up as ‘child’ devices? Personally I think they should. They do in HE.
If so, I think the problem is solved as each child device can then be treated as its own individual entity.

1 Like

Don’t forget that the drivers had to be reinvented there.

I think they all show up. Check the device in zigbee and see in there what assets you have to control.

I was a bit worried about that node you showed in the Screenshot. Wherever that is. Don’t mess with it.


Looks like he updated the z2m node from the CORE shipped version. I did the same and haven’t broken anything yet, I was confused when I moved things from my old NR server to core and was missing the ability to set the device via msg.topic

1 Like

Looks like I’m going to have to give up with this. Tried re-pairing again. Found it but kept saying offline.
I decided to delete device and start again.
Now when it pairs it says it is an unsupported device.
Yesterday it correctly identified it as a LIDL 3 outlet strip.
Tried 3 times and results are the same.

I will try dragging the strip closer to CC as it is around 15 metres away. Did the trick. Now to play again.