Node-RED 3, Wireguard, DDNS, HA0 removed, Local DNS Server

A little notice about the “CORE only”, “LAN only” and “Internet”. Unless you want to route ALL your Internet traffic through CORE, use either “CORE only” or “LAN only”. Once you change for a client, remember to scan the QR code anew to get the current settings.

image

I’ve just updated, was able to move my node-red-3 data over without too much of an issue. I also rebooted to make sure things will continue to work as expected.

Couple things:

  • What is the correct way to set our own DNS server (doesn’t seem to be using the DHCP supplied one)?
  • There is still an [email protected] interface pulling an additional IP

I had to run update again restart sysapi and firewall to get things going. I also removed the static ip reservation. But, I’m on a udm and they play weird jedi mind tricks sometimes.

This relates to different areas, tell me where you’re checking.

Here too. I have already tried re-running the update and rebooting Core.
EDIT: Although I do have a reservation for the eth0 interface in my DHCP server. There is currently NO reservation for ha0eth0.

Ok I fixed it by removing an old /etc/network/interfaces.d/eth0.dpkg-old that probably needs to addressed by @markus

node-red was unable to resolve my local hostnames and I was also unable to resolve them from the shell. I can add my local nameserver to resolv.conf (which worked). With the addition of the local DNS server, I’d like to make sure I’m changing it in the appropriate place which would survive any reboots which it does not by just changing resolv.conf

Please pull any relevant logs for him on both of these issues, if you would. When I talked to him this morning, he had an update that he would push later when he woke. He spares me the pain of pushing updates and then going to bed.

@cesarvog just leave it for now. It won’t hurt anything. Getting rid of this has been picky. Markus may want some further information from you.

2 Likes

:rofl:

How nice of him…

1 Like

:rofl: :rofl: :rofl:
:face_with_raised_eyebrow:
Seriously, Don’t remove those files. I want Markus to have a look.
:kiss:

1 Like

Not much to give him log-wise. He will understand that the dpkg-old file is just the previous version of the interfaces config before he commented out the ha0 interface stuff. The system just treats it as an additional config.

For the DNS stuff, I’m not sure if he plans to give a UI option for configuring local DNS, will add it from the DHCP information or if we need to install/change our own config for dnsmasq.

I’m very familiar on how to get things to work in Linux but always want to do things correctly from a CORE perspective. I want to make sure that he doesn’t also have to troubleshoot any customer changes. I will say that normally there is an expectation that any system should honor the DNS configuration given to it in DHCP. But with all the changes Wireguard is bringing, it can be a delicate dance.

2 Likes

Yes, done with the latest update

The local DNS-server on CORE will now forward queries to the DNS servers provided by the DHCP server, if any, the fallback is the Cloudflare DNS servers. An option to override the DNS servers used will probably be added to the UI at some point.
The exception to this are hostnames related to CORE, they will resolve to the correct IP depending on which interface the DNS request comes in on.

I appreciate that :slight_smile:

ha0 should not exist anymore after this latest update, please let me know if it still is.

EDIT: If you want to see which DNS servers are currently used, run this command:

cat /etc/dnsmasq.d/20-dnsservers.conf
4 Likes

It’s gone now, after updating again this morning.

Merry Christmas, everyone!
:santa:

5 Likes

Both issues look good now. thanks

3 Likes

5 posts were split to a new topic: How are errors indicated in NR3 function nodes?