Zwave JS UI disabled yet working

For versions and SYS|Dash, I see Zwave-js-ui disabled, but I can confirm it is working just fine.

Any ideas?

It is possible to reach such a state, but could just be a temporary connection issue with the API. what does the following command output?:

sudo oll-zwave-js-ui --status

Summary

[email protected]:~$ sudo oll-zwave-js-ui --status
INFO: Running command: status
INFO: Status of the Z-Wave JS UI container…
● podman-zwave-js-ui.service - Z-Wave JS UI in Podman (CORE)
Loaded: loaded (/lib/systemd/system/podman-zwave-js-ui.service; disabled; vendor preset: disabled)
Active: active (running) since Tue 2022-10-18 16:43:55 MST; 2 months 2 days ago
Main PID: 2395592 (conmon)
Tasks: 26 (limit: 4212)
Memory: 40.3M
CPU: 56min 38.732s
CGroup: /system.slice/podman-zwave-js-ui.service
β”œβ”€2395566 /usr/bin/fuse-overlayfs -o ,lowerdir=/home/oh-la/.local/share/containers/storage/overlay/l/PD2KLI4MJFU47PMIH56C6I54MU:/home/oh-la/.local/share/containers/storage/overlay/l/VRKOQOWCUDZJDKBV6MMYQQ4KTR:/home/oh-la/.local/share/containers/stora>
β”œβ”€2395569 /usr/bin/slirp4netns --disable-host-loopback --mtu=65520 --enable-sandbox --enable-seccomp -c -e 3 -r 4 --netns-type=path /run/user/2000/netns/cni-e5ee3e00-67c7-2870-0d83-f3f711f62946 tap0
β”œβ”€2395571 containers-rootlessport
β”œβ”€2395579 containers-rootlessport-child
└─2395592 /usr/bin/conmon --api-version 1 -c 968f3a942514cdf4028ba267ec355e8031ad6c7d819acf8fc2541d9c8f8b4f65 -u 968f3a942514cdf4028ba267ec355e8031ad6c7d819acf8fc2541d9c8f8b4f65 -r /usr/bin/crun -b /home/oh-la/.local/share/containers/storage/overlay->

Dec 20 19:14:54 Collective-Core conmon[2395592]: 2022-12-20 19:14:54.877 DEBUG MQTT: Publishing to zwave/Front_Entry/Front_Entry_Overhead_Motion/38/0/currentValue: { time: 1671588894877, value: 99 } with options { qos: 1, retain: true }
Dec 20 19:14:54 Collective-Core conmon[2395592]: 2022-12-20 19:14:54.879 INFO Z-WAVE: Node 9: value updated: 38-0-currentValue 99 => 99
Dec 20 19:14:57 Collective-Core conmon[2395592]: 2022-12-20 19:14:57.784 INFO MQTT: Message received on zwave/Becca_Room/Becca_Room_Light/38/0/targetValue/set: β€˜99’
Dec 20 19:14:57 Collective-Core conmon[2395592]: 2022-12-20 19:14:57.786 INFO Z-WAVE: Writing 99 to 47-38-0-targetValue
Dec 20 19:14:57 Collective-Core conmon[2395592]: 2022-12-20 19:14:57.845 DEBUG MQTT: Publishing to zwave/Becca_Room/Becca_Room_Light/38/0/currentValue: { time: 1671588897844, value: 99 } with options { qos: 1, retain: true }
Dec 20 19:14:57 Collective-Core conmon[2395592]: 2022-12-20 19:14:57.846 INFO Z-WAVE: Node 47: value updated: 38-0-currentValue 0 => 99
Dec 20 19:14:57 Collective-Core conmon[2395592]: 2022-12-20 19:14:57.848 DEBUG MQTT: Publishing to zwave/Becca_Room/Becca_Room_Light/38/0/targetValue: { time: 1671588897848, value: 99 } with options { qos: 1, retain: true }
Dec 20 19:14:57 Collective-Core conmon[2395592]: 2022-12-20 19:14:57.849 INFO Z-WAVE: Node 47: value updated: 38-0-targetValue 0 => 99
Dec 20 19:14:57 Collective-Core conmon[2395592]: 2022-12-20 19:14:57.857 DEBUG MQTT: Publishing to zwave/Becca_Room/Becca_Room_Light/38/0/currentValue: { time: 1671588897856, value: 99 } with options { qos: 1, retain: true }
Dec 20 19:14:57 Collective-Core conmon[2395592]: 2022-12-20 19:14:57.858 INFO Z-WAVE: Node 47: value updated: 38-0-currentValue 99 => 99

Refresh the page and if that doesn’t help, try restarting sysapi through the UI or with this command:

sudo oll-core-sysapi --restart

neither of those helped, but sudo oll-zwave-js-ui --enable did the trick.

1 Like