Z-Wave Update Tool

We’ve finished and pushed the Z-Wave update tool. Please refer to the documentation BEFORE you attempt to update your stick. These can be touchy.

I rarely say this -
Updating this is at YOUR OWN RISK. We’ve successfully updated all silicon labs sticks in our possession.

Run updates.


Just updated my Zooz zwave stick successfully. Thanks…

I am having a few problems having updated the firmware of my Silicon Labs UZB7 to v7.18.3. It appears to have worked OK but lost contact with a number of Z-Wave devices defined on the stick.

Still trouble shooting but thought I would post this as an early warning. :confused:

Subsequent to the FW update, I think there may have been a conflict with Z-Wave running on my Indigo system? Indigo was perfectly OK prior to the update.

Core lost contact with a Secure SSR303 boiler switch and I couldn’t get it working. So I used Indigo to exclude it and included back into Indigo. Then Core was causing odd issues on the Indigo connected device e.g. I could turn on the Boiler switch but not turn it off. When I physically pulled the Z-Wave stick from CORE, Indigo started working normally again.

As the boiler switch is important for our heating, I have had to leave the Core Z-Wave stick disconnected.

So I guess this comes under the category “Updating this is at YOUR OWN RISK” :stuck_out_tongue_winking_eye:

Luckily, the only important Z-Wave device I had on Core was the boiler switch and that is for the moment sorted.

I have saved the firmware update logs in case they are wanted but AFAICS it all worked OK.

I will revisit this in due course.

Technically, Z-Wave should not overlap.
There’s nothing wrong with the firmware because the update happened and completed. There are more likely differences in firmware between the two controllers. I’d allow some time for it to settle. Which is hard. Even for me.

I’m having a few issues with zwave inclusion and was wondering if there Is a way to revert to a previous zwave version?
This would be just to prove if things are ok on an older version and the newer version is the issue.

It’s not recommended. But, I can tell you that I’m on the latest and it’s working perfectly for me. did you update to the latest zwave js ui?

I’m not 100% sure what you mean but all I can say is I am up to date with the latest CORE updates.
The only reason I asked about reverting is someone else has mentioned issues with the latest firmware.

I’m not at home to get the exact command but run versions to make sure that zwave shows latest.

I did add three test devices to the UZB7 with the initial firmware and there was no issues what so ever. Then I did update the stick to 7.18.3 firmware with help of the tool created by @markus and everything went smooth without any errors like the 0x18 mentioned in the docs. After this I did a hard reset of the UZB7 in Z-Wave JS UI, just to start off with a clean slate.

Now, either the update failed after all or there are something else causing the stick to misbehave. There are now no way to exclude or include devices any longer, so I’m experiencing the same issues as @bobbles. I do have a second older Z-Wave stick that I tested, just as a confirmation that there are nothing else at play here… and without any issues the device was included.

I might add that he region is set to EU for both sticks, and also double checked on the UZB7 before the update.


While not ideal it does make me feel better. Thought I was going mad…
Maybe we need a z-wave revertion tool @april.brandt. :wink:

I have another stick on order. I will just plug it in and see what happens.


New stick turned up and installed. Version is 7.11.0.
I can now pair z-wave devices.
I’m making the assumption that the update has somehow corrupted the previous stick.
Who knows. :man_shrugging:

1 Like

I can’t speak as for why the latest 7.18.3 firmware is causing issues with pairing, I had issues at first with that firmware as well, but once I ran exclude a few times and paired a powered device it all works as before.
What I can say regarding the updates, once the device is flashed and responds to API calls (which is shown by Z-Wave JS UI by showing the controller as online) it is completely flashed and there can’t be corruption since the checksum has then been checked against. Sending a soft reset may be needed, but no more than that.
On your new stick, did you switch it to EU frequency?

1 Like

Yes. Set to EU.
As said before, I can occasionally get a battery powered Fibaro Motion sensor to pair OK but it goes unresponsive.

Did you manage to resolve this.
Just wondering before I invest too much time into including stuff on an old FW build.

Nope… haven’t made any more trials to be honest. But I’ll follow the example by @markus and perform few more exclusions together with perhaps a soft reset as well, not today though, then report back my progress in this thread.

Today I did a reset of my z-wave controller, before reset I didn’t do an exclude of any of the devices. Just to make it extra hard. After reset I did an exclude and then once excluded I did the include. All working.

Normal Power Level I’ve currently got it set to 4dBm and I’m using the EU frequency. I do hope those of you who are having problems with v7.18.3 can get it to work, there shouldn’t be issues. It can be fairly painful to get it all sorted, but it should work.

In the update process, if device is at 7.18.3 the update will fail 0x18.
I’m seeing this if I run through the update process again.
Is there a way to somehow mark the device as not being at the correct version so that it forces the update again.
Maybe there was a problem during the update process.
Just trying to think of things to try.

Don’t know how big influence this will have, because if memory serves me right mine is set to 3.3dBm.

1 Like

OK folks.
I just bit the bullet and decided to update my 7.11 stick to 7.17.2 using Simplicity Studio.
It updated OK and I can now exclude and include devices OK.
I’m not sure where this puts the issue but hey, I think I’ll leave at 7.17.2 until I know more.