Time for the ultimate test?

The time has come for the ultimate test. :wink:
We are going on holiday for 10 days and I’m going to have to leave my CC to fend for itself. :smiling_face_with_tear:
Will it get lonely? Should I leave a light on? (Hmm. That won’t work as it will turn the light off. :slight_smile: ).
99% of my rules/pistons are now on NR.
All my zigbee devices are on CC.
Z-wave is still on my C7.

Should I worry?
Do I need to get someone to house sit and read it a story every night?

I don’t think so…
The only problems I have had have been self inflicted. (NR learning curve. Wiring in a live outlet and tripping the main breaker!!!).
Only one zigbee device has dropped off and this is the furthest away from my hub and was paired direct to the hub in the early days. I have since re-paired it and it is now going through a repeater. No issues since doing this.
Will I be checking my HE dashboard every day? Of course just to confirm what I already know…
It’s happy to be left alone to fend for itself.
Wish me luck folks!!! :grin:

6 Likes

Having done the same thing with a ten day holiday all was going well until NOW Broadband did an IP change on the 3 October and from feeling like I was on the same network thanks to Tailscale I have been unable to log in because the router needs a power reset… So may I suggest you put a mains plug on the router and monitor several external IP’s and power the plug when they all don’t respond.
As for me, I am moving to Vodafone Broadband and installing the IP check as well as soon as I get home.

Oh, and have a great holiday!

3 Likes

Just reading this has me thinking.
Are you using Tailscale to access your CC remotely?
I thought someone had loaded it on to CC but it caused issues.
Thanks.

Guilty on both counts m’lord.
Yes I can be anywhere in the world with an internet connection and log into my Core as if I was at home so all my 192.168.100.x just appear, no port forwarding, open ports or black magic required. I tried, and failed to get Tailscale working as a Exit Node and allow Subnets so I could pension off my 2010 Dell laptop but it clashed with Cores firewall but I do have it installed without those and it works fine. In fact as I have the Dell passing the subnet info I don’t even need Tailscale on the Core. It takes less than 30 minutes to setup and nothing is easier, more info just ask

I’d be very interested in how you did this.
I’m due on my hols tomorrow so I’m not going to risk playing now but maybe something that I could look into on my return.
Just to be cheeky, maybe you could document how you got this working on a new ‘Remote Access using Tailscale’ thread so that others like me can see if we can set it up. Just a thought and is entirely up to you of course.
Thanks again.

1 Like

I will but when I get home and finally shake off this cough/cold/flu (not man flu, my other half has it as well) as we have had to curtail our travel and booked several extra nights on our caravan site as I just feel [email protected] and driving a 22 foot motorhome in Kent county lanes (or even the motorway) just does not appeal at present.
Have a good holiday, stay away from people coughing, after two years this one has a bite to it, triple UK winter coming with covid/flu/barking cough, can’t wait until December, off to Oz for 8 weeks of sun.

2 Likes

You’re right, some nasty ones going around at the moment.

Very, very nice. Never been. Flown over it to New Zealand. Massive country Oz. It seemed like we were flying over it for hours.
Have a great time.

1 Like

You are probably running a router node in your dell. I have a Tailscale router node in my raspberry pi 3B plus running Tailscale router node, Wireguard and pihole for a while now without issue.
I hardly use wireguard now but it’s kind of my backup when Tailscale is not working.

Last time we went just before covid we flew from Perth in WA to Sydney, over 6 hours in the air, yes it is a big country but most of the population are within 30 miles of the coast, lovely country we have gone every year since 2005 (with one covid exception), we visit my other half’s daughter and family so no horrendous hotel bills, just the 20 hour flight.

I was but Core errored as soon as the firewall tried to load, long before Tailscale on Core was even called, tried everything in the Tailscale readme but thankfully @markus got me back up and running so as long as you have a linux/pi running then it will work, when I am back home I will do some test to see what is/isnt needed. Using the Tailscale 100.x.x.x should be the easiest but for me using the same 192.168.x.x shortcuts is what I would go for using subnets, just it may now be cheaper to buy an old Dell/HP laptop than a Raspberry Pi!

Following this… I too would like secure remote access to my Core…

Yeah, not sure about Core but I didn’t have any problem install Tailscale on HA before. Guess Core has some crazy firewall compare to no firewall at all with HA.

BTW, It Is not clear to me the pros&cons of Tailscale vs WireGuard. I’m using a WireGuard on Rpi with no problems at all since a couple of years.

If it isn’t broke don’t fix it.

For an in depth review of Tailscale vs Wireguard then take a look at Tailscale Vs Wireguard for me with 11 devices on Tailscale it just takes seconds to add another and items like Hubitat which cannot load Tailscale I just fire up Safari and point to 192.168.100.170, having never used Wireguard I am not sure if WG needs to be on every device or it can do the same as Tailscale

For me it is easy to understand and quick to impliment, I just could not get my head around Wireguard or ZeroTier.

Ok, lets ask the basics.
Do you have an always on computer on the same network as your Core and if so what Operating System is it running?

Nope. I was hoping it could be installed onto Core… maybe in a separate container…?

What router do you have?

It can be install as a Tailscale node but to use the same IP as your local network one device needs to be set as a subnet router and that screws up Cores firewall so I used an old Dell D600 laptop with linux Mint and installed Tailscale with subnet router and exit node but I suppose the question is does Core really need a firewall in the first place and can it be turned off or is it integral to Core.

I’ve been curious about this aswell!

If you pay attention to the general format of oll commands, or make use of the --help commands you could quickly figure out how to disable the firewall entirely.

It is HIGHLY advised against doing this, unless you are EXTREMELY confident in your ability to secure your devices and network yourself.

Personally I would advise against doing so until a full suite of system restore tools is available. At its heart core is a nix system, and currently, if compromised and locked down by an external party will REQUIRE sending your CORE back to April/Markus to be restored.

Since this is outside of the current recommended usage, I imagine you may have to pay for the restoration service, and at the very least would be paying for the shipping both ways.

2 Likes