Sonoff T1 R2

Hi All, I’m trying to flash a Sonoff T1 R2 V1.1 (2-gang), so that I can use it with HE.
I have my trusty FTDI, got the Touch T1 R2 into programming mode by shorting R19 to ground, download started (send receive lights flashing away)… after a short while everything stopped - no activity whatsoever.

Now when I power on the T1 it looks like it is going straight into programming mode - but zero communication taking place.

Have I bricked it???

Ahboy. I’m not sure about the flashing part. I think that @markus might be able to answer that question, but it’s late there. When I chat with him I’ll mention it if no one has chimed in with the answer. I’m the type that if I think I bricked it, I’ll try it again. But I’m not encouraging you to do that. I’m just a kind of nothing to lose at this point thinker. But wait for a better answer. I’d hate for there to be a simple answer and you were just like eff it. Gonna try it again.

I don’t have personal experience with these boards, but there were changes to the flashing procedure between v1 and v1.1, were you aware of the differences?

  1. There is not enough room with this version to solder header pins to the programming port and still close the case. One possibility is to slightly bend the pins of a 4-way header and push it into the holes, removing it after programming. 2. GPIO0 is connected to the helper chip on this version, so the only way to get Ver1.1 of the board into flash mode is to solder a lead onto the resistor R19 from pin 15 on the ESP chip (GPIO0) and connect this lead to GND on power up; the device will set all the touch pads to dim and the WiFi LED D3 will NOT be on at all. 3. The connection marked ‘LOG’ on the J3 header is GPIO2.

WARNING!! Do not attempt to power the device from your serial-to-USB adapter when connected to the relay board. This draws too much power and will cause the ESP to reboot frequently and reset all the configured settings.

Thanks April. I’ve tried it a good few times now and nothing happening… maybe there is a simple solution - maybe I just need to go get me another one.

Yes - on V1.1 you short R19 to ground when powering on. That’s what I done to get it into programming mode initially.

1 Like

I also saw mention of the boards detecting a long press after flashing under some circumstances resulting in the condition you described, but i have not come across a solution yet. So if nothing else that may give you a starting point for research and troubleshooting

1 Like

Yay. Got it !!!

I found another T1 R2 - this one an older V1.0 - and to my surprise ended up in the same boat - device went into programming mode fine, but no communications.

So - process of elimination - I found out that one of my wires from the FTDI to the device had gone bad… New wires and Tasmota installed just fine, went then to the original device that was giving me grief and Tasmota installed there just fine also…

Many thanks April and Rob for your assistance and suggestions…



Yay! I’m so glad you got it worked out. Keep it in mind as you may be leading someone on to the same issue next time the question gets asked. Thanks for posting the solution.