PSA: Z-wave JS 10.0.3 and ZwaveJS2Mqtt 7.0.0 not ready for primetime

Just an FYI, I had severe issues with the latest versions of Zwave software - see this issue on github for details. Others are also having issues with the 10.X code branch, as indicated by the comments above mine. WAF could not live with non-functional garage door remote control, so I’ve downgraded to versions 6.16.0 and 9.6.2. Everything back to normal…

Also FYI, downgrading by editing the oll-zwavejs2mqtt.conf file was really easy, and worked perfectly! Thanks, @markus for taking what would have probably been a painful procedure for me and making it smooth.


We looked at the bug report and those you using Z-Wave should roll back to 6.16.0.
We have frozen Z-Wave at 6.5.2 but will be changing that in the next update. 6.16.0 is stable.
If you haven’t changed your tag, don’t. If you’ve upgraded to 7.0.0, we suggest you roll back.

How to do that:

sudo nano /home/oh-la/data/zwavejs2mqtt/oll-zwavejs2mqtt.conf

using your arrow keys:
arrow down to where you see CONTAINER_REPO
and change latest to 6.16.0


Then crtl+x

Then run

sudo oll-zwavejs2mqtt --update

Once that is finished run:

sudo oll-zwavejs2mqtt --restart

It may take a few minutes for that to come up. You can always pull up the logs if you begin to worry that it’s not starting.
If you’ve upgraded past 6.16.0 please do NOT downgrade below 6.16.0. There could be breaking changes.

1 Like

Update: the issue I saw with the 10.X branch turned out to be a combination of two things: ZwaveJS 10.0 and above use stricter checks when interviewing nodes (adherence to the rules), and the Zen16 firmware was lacking. It was (at the time) the most recent Zen16 firmware, but it wasn’t up to par with zwave standards for multi-endpoint nodes. Zooz supplied me with a beta version that supposedly fixed the issue, which is now in public release. I procrastinated for weeks, since the WAF were always around and I didn’t want to break anything without having sufficient time to roll back.

Tonight was the night - they all vanished, and I took the dive. I flashed the new firmware and updated to ZwaveJS 10.3, along with ZwaveJS UI 8.2.1. All it took was modifying the target tag to “latest” in the oll-zwavejs2mqtt.conf file, running an update, and restarting. After the update I included my Zen16 again, and everything works perfectly. All my other nodes seem to be working well (I haven’t tested extensively).

So far so good with the new code base… I’ll post an update in a few days to a week. FWIW, my zwave mesh is mostly Zooz, with a few other devices sprinkled in (Ecolink contact sensors, Fibaro multsensors, Sensitive strips).


1 Like

Instead of doing this, you can just switch to “oll-zwave-js-ui” now. Just want to keep it clear for those who are wondering.


I saw the new command - our posts crossed in the mail! :grin:

1 Like

So far, so good with ZwaveJS 10.3 and ZwaveJS UI 8.2.1… all automations have been working flawlessly, and I haven’t seen any bad behavior from any of my Zwave nodes. I’ll be curious to see how my Zwave mesh responds when a bunch of repeaters go dark - as soon as my Inovelli Blue switches come in my Zwave mesh will be much more sparse.

I did experience a bit of latency, with Z-Wave, but I wonder if it was just the network working itself out mesh wise after the update. I haven’t had any ill behavior since.
command to update to Z-WAve JS UI is:

sudo oll-zwave-js-ui --enable

WARNING: This will disable zwavejs2mqtt. You can’t have both running.

1 Like