New Zigbee 3.0 USB Dongle Plus–ZBDongle-E

3 Likes

I have the Dongle Plus and it is working well. I have often wondered though what the “flow control” firmware support actually means and whether it is important. I know what flow control is in a serial data transfer sense because I am very old indeed, but what does it mean for the dongle? If you don’t have it can you overrun the zigbee chip? I have of course reflashed my firmware so I might have flow control available.

Looking at the serial setting in z2m, I see that RTS/CTS is not ticked and that baud rate is note set.

1 Like

Figures there’d be a latest and greatest after I bought the old one lol.

4 Likes

Is it any better really though? Other than increased default power transmission level (which can be set on the old stick) it is based on a different SoC and implements a different protocol. In practice, what does this mean to us? Is EZSP inherently better than ZNP? The board is a bit smaller, but that is not a big deal.

2 Likes

Lol I am sure I would not know. Th e latest and greatest is always better though right??

1 Like

I would not recommend the ZBDongle-E since EFR32MG21 is not truly as well tested and supported with Z2M as CC2652P.

4 Likes

As the ZBDongle-E is by default 20dBm and the ZBDongle-P defaults to 5dBm, what are the pro’s and con’s of upgrading the ZBDongle-P to 20dBm and does the Koenkk Z-Stack-firmware auto upgrade to 20dBm as I have flashed my ZB-P to a router with the Koenkk Router Z-Stack-firmware.

1 Like

If you have at least the 20220726 firmware from Koenkk installed on the ZBDongle-P you can then manually set the power being transmitted from the default of 5db to anything up to 20db using the z2m configuration - https://www.zigbee2mqtt.io/guide/configuration/adapter-settings.html

If you open the zigbee2mqtt dashboard and select Settings->Advanced and scroll to the bottom you will find the transmit power setting.

I thought that setting was for the Coordinator which I have an Electrolama-ZZH stick which I think is fixed at 5dBm, the ZB-P I am using as a router flashed with the latest Koenkk Router Z-Stack-firmware.

1 Like

IMHO I feel like having a powerful antenna on your controller could be an issue. You don’t want to have a controller with a stronger antenna than your weakest device. I think that could cause mesh issues. Thoughts?

I suppose the best option is swap the 2 sticks around so I can control the power output on the Sonoff ZB-P as the coordinator and the ZZH just becomes a router, I do have 2 x Moes Tuya ZigBee Signal Repeater Amplifier USB Extender’s on the way so I don’t need to swamp the network.

Can you elaborate on this? I bumped up my Tx power from 5 to 20dBm and all my lqi values for directly-attached devices nearly doubled - from < 100 on most repeaters to nearly 200. Endpoints making use of routers haven’t changed their routes, which is good - I selected those routes manually when pairing, and I want them to persist.

Since April is at work I’ll field this one.

Basically your end devices have a limited transmit power that can not be turned up. Turning up the coordinator transmit power will only help end devices receive messages from the coordinator, not send them to it.

Because of this you can end up with a network that reports good looking LQI while having a bunch of devices that are having issues actually sending to the coordinator.

Result everything seems to be working but behind the scenes you have messages from end devices being sent multiple times before they can reach the coordinator, and you have other devices not grabbing new routes because from the device perspective it can see the coordinator just finem, why would it need a new route?

From your perspective everything is going great, you cant even notice the extra 100ms that have been added to some of your automations because the end device is having issues getting its “voice” heard, because it does eventually get heard.

Fast forward a few days or weeks… All your battery powered devices have been devouring batteries and you can’t figure out why, Having suspicions that your having mesh/routing issues, you move or add a repeater to your network…

UH OH… Because of the coordinator strength your new routing device is ignoring the others believing the coordinator to be the best route and suddenly half your network drops off because its trying to route through a repeater that can’t actually reach the coordinator.

Personally the only way I would ever think about setting my coordinator to 20dbm is if I was using other 20dbm sticks as my routers.

2 Likes

Convincing, thanks! Moving back to 5dBm…

1 Like

Yes I think I will stick with default of 5dBm and forget the 20dBm as well.

1 Like

:point_up:
Teacher … nodding her head.
@CliveS , @epw
“You’re growing up pookie.”
:wink:
Thanks @RRodman for the outstanding explanation that I didn’t quite have time to write yet.
:kiss:

2 Likes

Anytime Dear :green_heart: