Local Plex Streaming Buffering Issues

Not the usual thing to be on this forum, but hey you guys are a knowledgeable bunch and this has got me stumped.


  1. I have an Unraid server that hosts movies (mainly 4k remuxes) on x4 HGST HUH721212ALE600 drives using a Plex server primarily. It is wired directly to the Orbi router that has wireless backhaul to the other 2 satellites.
  2. I also have my main client as an Nvidia Shield TV Pro that is wired into one of the Orbi satellites.

So the issue is that when I am streaming one of the higher quality 4k remuxes (~80Mbps for 4k hdr + ~5Mbps for lossless audio) I am constantly running into buffering issues even though I am not doing any transcoding. I have tried the Plex app for Android, I have also recently played around with Kodi and it’s various add ons for Plex (Plex for Kodi, Composite, and PlexKodiConnect) and the issue always seems to be present. I even tried directly mounting the samba mount from unraid onto Kodi and it even buffers then.

While streaming, the Unraid server shows as uploading ~90Mb/s with spikes up to 120Mb/s. I have installed the docker container for an open source self hosted speed test on the Unraid server and have run a test from my Nvidia Shield and it yields less than 3ms of ping, 0.3 jitter, around 600Mb/s download and around 350Mb/s upload. I also installed a disk benchmark utility than scan the speeds at the various fill levels of the drive, and when the drives are empty they have a read speed of about 300MB/s and when nearly full they go down to about 120MB/s.

I have no clue how any of this adds up to me having buffering issues, the drives should be able to read plenty fast and the network should be plenty fast to transmit the data.

So I thought it has to be a software issue on the shield tv side (potentially to do with buffer sizes) so I messed around with the advanced settings of Kodi (installing the OpenWizard add on) and used their high end device network preset which makes the readfactor 15, buffermode 1, and the memory size to 3GB iirc and the same issue is present, it is arguably worse now…

Does anyone have any experience in this realm or have any other ideas on ways to troubleshoot? I am simply at a loss since it seems the shield tv is just refusing to ask for more bandwidth when it definitely can. All of the hardware tests to my eyes says this should not be a problem.

Help me Obi-Wan Kenobi, you’re my only hope.

I’d work on narrowing down portions of the problem.

Can you get non-Kodi (VLC?) to play with no buffering issues. Possible to temporarily move a video to the Shield and see if Kodi struggles locally?

This might help point to the culprit. I just wish my old man eyes could justify 4k remuxes (first world problems …) :slight_smile:

1 Like

Try streaming from a laptop or desktop with wired connection as well. This will at least eliminate if the client is the issue.

I had this. I think you’re looking at hardware when you should look at your plex configuration. That’s where my problem was. I can pull my settings in a couple of hours and post them here. Maybe you’ll find something there.

a couple of things you can check in your Plex server settings page:

  1. Set your preferred network interface rather than “any”
  2. Enable local network discovery (GDM)
  3. Set your NVIDIA Shield Pro IP in the LAN Networks field

I throttle internet streaming down to 720p

Under "remote access for server

Checking that itunes box causes issues. If it’s checked, uncheck it.

I have a computer with a video card, so I can transcode if needed.

1 Like

@Cjkeenan Well? Don’t leave us hangin.

Sorry about that, I have been out of town this weekend, but I plan to head home tonight and take a gander at my settings. Unfortunately, if my memory serves me correctly, most of the settings you guys described I already had (mostly because I had to deal with plex during an internet outage), but we will see. I plan on trying to stream using another device connected to the same Orbi as the shield tv. I am also going to download VLC on the shield and see if that helps. And then finally I am going to put one of these files on a usb drive and see if I can just locally play it via the shield.

What client software do most of you use? Just the default Plex app?

Default plex app. That itunes checkbox totally messed with my stuff. Just sayin

1 Like

I assume leaving LAN Networks blank is fine since I only have one subnet (192.168.1.X). Everything else that you suggested was already in place.

Mine was already disabled.

Edit 1:
I am playing the video file in question right now on VLC over WiFi on my desktop, so far, no issues…
These are the stats after 5 minutes. 6 frames lost does not look like anything to worry about. Unraid server reporting outbound of up to 20MB/s which I never saw using the shield tv.

Edit 2:
I guess I made progress? It just seems so inconsistent. I read online that the Logger buffer size in the shield’s developer settings being set to 16MB (max) would help especially with 4k hevc hdr remuxes. It seems to be working? I will have to test more to find out.

Edit 3:
It is just really confusing, because you have threads like this were there are tons of people saying my exact situation should not be happening:

Edit 4:
I am going to try this tomorrow and see how it goes, apparently there is a new option inside the Plex app that needs to be turned off. I am skeptical however since I would think that Kodi would not have any issues then…

If this does not help, I think I might just factory reset and only install Kodi and try direct streaming from samba, back to the very basics, then move up from there, it seems that the Plex client as of late has a been an absolute crapshoot (at least according to Reddit), so if I could get Kodi working with pkc I would be happy.

@Cjkeenan I noted from your screenshot you have relay enabled try unchecking that, change your preferred network from any to your LAN one and set the IP for your NVIDIA Shield Pro. I had what you described before if I didn’t do that.

Also the only other issue I have experienced before was with dolby vision files as my NVIDIA Shield TV Pro wouldn’t always play them and lead to buffering issues. In the end I excluded those types from Sonarr and Radarr and problem solved. Below are my settings for both platforms.

Sonarr - located in profiles section

Radarr - located in custom format section

1 Like

I tried turning the I/O Caching off in Plex and it seemed to help, but then it buffered…

done, no change unfortunately

Cannot do that unfortunately since this is inside a container so my normal subnet isn’t an option to choose from.

I saw that as well, unfortunately, the files in question are only HDR10.

1 Like

It would be worth trying it without a container. Plex might be one of those services that doesn’t like fences. If it works outside of the container, then it might be worth tweaking the container networking settings. Wowza a ton of challenges when this is inside a container.

I don’t really have that option, at least not easily, remember this is all hosted on Unraid and up until recently I haven’t had a single issue.

oh yah … I forgot about that.

trying a shield factory reset, :crossed_fingers:

I jsut searched it out and there are a ton of complaints on reddit.

1 Like

just picked at a few of these on reddit, might help you out? I don’t have an unraid, so i’m no real help.

(2) PSA for Plex on unRAID: How to fix slow browsing : unRAID (reddit.com)

Performance Issues with Plex - General Support - Unraid

the ones i find here keep mentioning caching location and paths. Did you happen to check that?

1 Like

So I think I am making progress, I turned off audio passthrough, heresy I know, but it hasn’t buffered yet, knock on wood. I wonder if I just need better HDMI cables…

1 Like

If none of the above sorts it out, maybe it could be worth trying running plex server on your desktop machine? Just to see if you don’t have the same problem when streaming from there. At least that may help narrowing down where the problem is.