Iris 3210-L2 Z-Wave failing to join Lifeline

So I started a thread over on the HE forums but never really got any useful info, so I figured I would try over here and see if anyone could help.

I bought a 10pk of IRIS 3210-L2 plugs from, side note 10/10 service, new never opened packaging with even the boxes pristine, but anyway, I paired all 10 via zigbee then Z-Wave. I am only currently using 6 of them but I noticed an oddity where the driver I am using states that “Group 1 not found, configure device!” and after configuring it does not help. Then I noticed that after a reboot and some time for the mesh to reestablish, only one of the 6 in use new plugs is actually listed in the Z-Wave table to have data being sent to or received from, see thread.

Any ideas? I was thinking of buying a UZB to make a Zniffer, would that help to determine if they are indeed part of the mesh and simply a bug on HE’s end or what? Anything would be appreciated at this point since no one seems to be able to help and the original dev for the driver seems to be gone for now.

PS, not sure if this should be under Z-Wave or under HE as far as categories go so let me know if I should change it.

I have these and was advised not to use the zwave repeater part. That was back when I was having terrible troubles with both mesh networks. Evidently causes issues with mesh. Firmware DOES matter with these. I had some older firmware ones. At this point there’s no way to really update them. So I unpaired the zwave side of them and use them for zigbee only. They’ve been solid ever since. Those are great plugs, but I don’t know if I’d mess with the zwave part of it any more. Are you on a C7? :frowning_face:

No, I have a C5

The weirdest thing is that apparently the L2 models have the most recent firmware and literally every single one I have tried returns the same error, where when I purchased x5 3210-L plugs, some with the extra sticker, and some not, but then paired them via Z-Wave, they all paired fine and joined the lifeline fine.

Do you know of any way to check what firmware is on there so I can compare to anyone that has a working setup? Also would an external Zniffer help in any way to detect if they are a part of the mesh?

It just occurred to me that I think there is a community driver for these. do a search. I can look when I get home later.

Yeah I am using it, with that driver, after interrogating the device, it says “Group 1 not found, configure device!”