Emporia Vue Utility Connect & Z2M

Does anyone here use the Emporia Vue Utility Connect to monitor the energy usage of the full house?

I had this working a while ago when I was using Hubitat for Zigbee, but when I switched over to CORE and left the permit join on for Z2M for too long, it tried joining my Z2M network, and began wrecking havoc.

Network slowdowns, constant not responding errors from more than just the Emporia Vue, and commands not being followed was common until I unplugged the Vue. I have since reset the Vue, reprovisioned with my utility compay, and even added the IEEE address to the blocklist on Z2M, but every time I power on the Vue, I see slowdowns in Z2M.

Any ideas what is going on?

P.S. Probably not related, but something I also noticed: Certain devices (have not seen a pattern) just drop themselves from Z2M after a reboot and I have to rejoin them.

I searched out Emporia in the compatible devices list and didn’t find it in Z2M. Have I searched out the wrong device? To me, it sounds like it’s flooding the 2.4 when it’s on. Is it close to your radio on CORE? Interference can take on many forms. Maybe try moving the device.

The only real way to know is if you are able to snif the traffic. Or, try using an app on your cell phone that can detect if 2.4 spikes when you turn it on. There are several free apps out there.

I do see that there are other complaints of interference when I google it, although I didn’t read extensively into it, it might be an angle to consider.

Also, you might submit a feature request to the Z2M Dev. If you’ve tried this tutorial. Having the proper driver might be the remedy as I didn’t find anything listed under Emporia in Z2M.

Yeah that is the thing. I was not trying to add it to my network. As I understand it, the utility panel itself (or at least the meter) is the zigbee device that connects to the Emporia Vue “gateway” and then it goes to their cloud/etc so you can get the data. The problem is it keeps trying to force itself onto my network and I don’t know why. With the Vue unplugged, my network is fine, once I plug it in, it connects to my meter and it all looks fine and it is reporting data to their app, but give it 24 hours and z2m starts being weird. Given that, I don’t think my meter is the issue (though it would be cool to directly connect a smart utility meter to CORE), it is the Vue gateway that is the problem (which seems very odd to me).

I believe someone has flashed ESPHome onto the Vue and got the data that way since it is just a ESP32 device, but don’t really want to go down that road right now and the wifi side is not really the problem it seems.

So this connects to wifi or your LAN network to send the data?

[EDIT]
Out of curiosity, have you tried putting it on it’s own vlan? something away from your smart devices? Wifi and z2m are both on that 2.4. Just really thinking out loud more than anything. The reason my thought is in this direction is because someone had reached out to me recently with terrible issues keeping their Shelly’s and other wifi devices on line. They had it running in a mixed network with 5 and 2.4 on the same ssid. And it went crazy with strange behavior and devices dropping. After moving it to a different network and vlan without a 5ghz sister network, everything calmed back down and started playing nicely again.

Again, just hashing through things here. Might be worth a try. I’ve experienced the same with other smart devices.

Yes, my understanding is that it communicates over Zigbee to the utility’s smart meter (using Zigbee Smart Energy) and then connects to wifi using an ESP32 chip which is how I interface with the device using their app or there is a community python utility to get the raw data (though I think that is a cloud interface not local).

No, I have never messed around with VLAN’s. I have a Netgear Orbi RBR50/RBS50 system with 5GHz and 2.4GHz on the same SSID for probably 5 years now and it has never really acted up in any major way.

I doubt it is a wifi issue since my zigbee network is what is freaking out. I guess unless we are talking about a physical interference issue, but that seems a bit unlikely since the meter and Vue are at the back of the house while the Orbi is at the front.

what Zigbee channel is your emporia running on? Markus messaged me and suggested it might be on the same channel thus interfering heavily.

Unknown, I do not manage the zigbee connection directly. I have to go through my utility and provision the device under their Home Area Network, and then after a couple of days it connects usually.

I don’t see any options anywhere to change it in the app either.

From their FAQ:

The radio signal is broadcast on a secure, encrypted, 2.4GHz ZigBee Smart Energy 1.1 standards-based wireless channel.

Core is on 11 and Hubitat is on 20. Here is the Channel graph for 2.4GHz, which I assume would also show zigbee and just say unknown ssid:

I have a sneaking suspicion that your meter is on 11. Given what you describe, the only difference is the channel and I’m sure that thing is pretty chatty. If you don’t have much on CORE, then consider changing the channel otherwise maybe the company can push a channel change for you on that device?

1 Like

How many client energy monitors are you using on your single Vue ?

It’s the utility connect one, so I don’t have any current sensors, it just wirelessly connects to the utility meter and gives the overall load of the panel.