Cannot update my zigbee coordinator dongle

After a long time that I didn’t update my sonoff dongle (last july), I tried to do it on my new pc with windows 11. I didn’t succeed because it couldn’t find the COM. I resurrected the old pc and tried again.
After “connecting to target” I got an error: “ERROR: Write timeout”.
Any suggestion about ?

python -p COM4 -evw --bootloader-sonoff-usb CC1352P2_CC2652P_launchpad_coordinator_20221226.hex
Opening port COM4, baud 500000
Reading data from CC1352P2_CC2652P_launchpad_coordinator_20221226.hex
Your firmware looks like an Intel Hex file
Connecting to target...
ERROR: Write timeout

I think he was talking about zigbee? I use the python script and have never had a problem. Have you installed the USB to UART bridge driver first? Once you have that, have you verified the COM port # assignment using device manager?


Doh!!! :blush: Of course… My bad…
Sorry for the dumb post @roberto . I’ll delete to spare my blushes. :grinning:

I did try to upgrade my zigbee Sonoff Dongle as well and couldn’t get the process to work for me either.
I did have the correct UART driver installed and the dongle was recognised in my PC.
I just gave up in the end as things are working OK.
It would be nice to update it though.

You have never to excuse with me :slight_smile:

1 Like

I’ve used the same PC (Windows 10) where I lastly updated my dongle on july.
Even more is seems impossible in Windows 11 to understand which COM# the dongle is installed in. The device manager looks different

I installed the above library on the windows 11 pc and … worked!
Thank you @epw
p.s. I still cannot understand why it did’nt work in the old pc I used it for before.

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.